PAT-A 真题 - 1117 Eddington Number

发布于 / PAT-甲级 / 0 条评论

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.

Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (105), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8

Sample Output:

6

题目大意:给定n个骑车骑行路程数据,使得连续E天骑行路程超过E的最大值。

这道题直接排序然后遍历即可。

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
bool cmp(int a, int b){return a > b;}
int main(){
  int n, E = 0, dat[100010];
  cin >> n;
  for(int i = 0; i < n; i++)
    cin >> dat[i];
  sort(dat, dat + n, cmp);
  for(int i = 0; i < n; i++){
    if(dat[i] > E + 1) E++;
    else break;
  }
  cout << E;
  return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题 - 1117 Eddington Number
目前还没有评论,快来抢沙发吧~