给定大量手机用户通话记录,找出其中通话次数最多的聊天狂人。
输入格式:
输入首先给出正整数N(≤105),为通话记录条数。随后N行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。
输出格式:
在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。
输入样例:
4 13005711862 13588625832 13505711862 13088625832 13588625832 18087925832 15005713862 13588625832
输出样例:
13588625832 3
这是一个散列查找的问题,但是我们可以使用STL标准库的map容器来解决这个问题。
代码如下:
#include <iostream>
#include <map>
#include <algorithm>
#include <string>
using namespace std;
int main(){
map<string, int> mp;
int n;
cin >> n;
for(int i = 0; i < n; i++){
string _from, _to;
cin >> _from >> _to;
mp[_from]++, mp[_to]++; //对应的通话次数++
}
int max = -1, num = 0;
//存放最大通话次数和并列人数
string pid;
//存放电话号
map<string, int>::iterator it;
//使用迭代器遍历map容器
for(it = mp.begin(); it != mp.end(); it++){
if(it->second > max){ //通话次数更大
pid = it->first; //执行一次完整的更新
max = it->second;
num = 1; //并列人数=1
}else if(it->second == max){ //通话次数并列
num++; //并列人数++
if(it->first < pid) //如果电话号码更小
pid = it->first; //更新电话号
}
}
cout << pid << ' ' << max;
if(num != 1) cout << ' ' << num;
cout << endl;
return 0;
}