The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!
For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M\$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M\$7) to get M\$28 back; coupon 2 to product 2 to get M\$12 back; and coupon 4 to product 4 to get M\$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M\$12 to the shop.
Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.
Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 10^5^, and it is guaranteed that all the numbers will not exceed 2^30^.
Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input:
4 1 2 4 -1 4 7 6 -2 -3
Sample Output:
43
题目大意:神奇的优惠券(老板这种优惠券给我来一沓)。
第一行给出优惠券的倍率,第二行给出商品的价值,注意倍率和价值存在复数,倍率*价值是购买后所得到的价值,求商品最大价值。
这道题是一个贪心算法的问题,只需要将正数负数分开存储,排序,分别将绝对值最大的依次相乘即可。
代码如下:
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 100001;
int main(){
int C[maxn], P[maxn];
int cntC, cntP;
cin >> cntC;
for(int i = 0; i < cntC; i++) cin >> C[i];
cin >> cntP;
for(int i = 0; i < cntP; i++) cin >> P[i];
sort(C, C + cntC);
sort(P, P + cntP);
int max = 0;
//从最右边开始,大正数相乘
for(int i = cntC - 1, j = cntP - 1;
i >= 0 && j >= 0 && C[i] > 0 && P[j] > 0;
i--, j--)
max += C[i] * P[j];
//从最左边开始,小负数相乘
for(int i = 0, j = 0;
i < cntC && j < cntP && C[i] < 0 && P[j] < 0;
i++, j++)
max += C[i] * P[j];
cout << max << endl;
return 0;
}