原题干:
本题的基本要求非常简单:给定N个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个"合法"的输入是[-1000,1000]区间内的实数,并且最多精确到小数点后2位。当你计算平均值的时候,不能把那些非法的数据算在内。
输入格式:
输入第一行给出正整数N(<=100)。随后一行给出N个实数,数字间以一个空格分隔。
输出格式:
对每个非法输入,在一行中输出"ERROR: X is not a legal number",其中X是输入。最后在一行中输出结果:"The average of K numbers is Y",其中K是合法输入的个数,Y是它们的平均值,精确到小数点后2位。如果平均值无法计算,则用"Undefined"替换Y。如果K为1,则输出"The average of 1 number is Y"。
输入样例1:
7 5 -3.2 aaa 9999 2.3.4 7.123 2.35
输出样例1:
ERROR: aaa is not a legal number ERROR: 9999 is not a legal number ERROR: 2.3.4 is not a legal number ERROR: 7.123 is not a legal number The average of 3 numbers is 1.38
输入样例2:
2 aaa -9999
输出样例2:
ERROR: aaa is not a legal number ERROR: -9999 is not a legal number The average of 0 numbers is Undefined
这道题比较适合使用sscanf和sprintf来做。这两个函数可以将字符串当做输入流,并格式化到变量中,也可以逆过来。具体使用方法:https://www.mmuaa.com/post-82.html
#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
bool str_equ(char* a, char* b){ //用来判断是否符合题意
if(strlen(a) > strlen(b)) //如果a的长度比b长,说明a没有保留最多两位小数,或者a后面有非法字符
return false;
for(int i = 0; i < strlen(a); i++) //循环a的长度次,防止类似"5与5.00"的数据被判定为不符合题意
if(a[i] != b[i])
return false;
return true;
}
int main()
{
int cnt, cnt_right = 0;
char str[100], str_ck[100]; //str为输入的字符串,str_ck为格式化为%.2f的字符串
double num, nums = 0.0;
cin >> cnt;
while (cnt--)
{
cin >> str;
sscanf(str, "%lf", &num); //将str格式化为%.2f的double型 num
sprintf(str_ck, "%.2lf", num); //将num格式化为字符串,用来比较
if (str_equ(str, str_ck) && (num <= 1000) && (num >= -1000)){ //无非法字符,保留小数位数相等,且在范围内
nums += num; //nums累计数据和
cnt_right++; //cnt_right给合法数据记次
}
else
cout << "ERROR: " << str << " is not a legal number"<< endl;
}
if(!cnt_right) //cnt_right不等于0
printf("The average of 0 numbers is Undefined\n");
else if(cnt_right == 1)
printf("The average of %d number is %.2f\n", cnt_right, 1.0 * nums / cnt_right);
else
printf("The average of %d numbers is %.2f\n", cnt_right, 1.0 * nums / cnt_right);
return 0;
}