The "travelling salesman problem" asks the following question: "Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?" It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from "https://en.wikipedia.org/wiki/Travelling_salesman_problem".)
In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then Mlines follow, each describes an edge in the format City1 City2 Dist
, where the cities are numbered from 1 to N and the distance Dist
is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:
n C1 C2 ... Cn
where n is the number of cities in the list, and Ci's are the cities on a path.
Output Specification:
For each path, print in a line Path X: TotalDist (Description)
where X
is the index (starting from 1) of that path, TotalDist
its total distance (if this distance does not exist, output NA
instead), and Description
is one of the following:
-
TS simple cycle
if it is a simple cycle that visits every city; -
TS cycle
if it is a cycle that visits every city, but not a simple cycle; -
Not a TS cycle
if it is NOT a cycle that visits every city.
Finally print in a line Shortest Dist(X) = TotalDist
where X
is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist
is its total distance. It is guaranteed that such a solution is unique.
Sample Input:
6 10 6 2 1 3 4 1 1 5 1 2 5 1 3 1 8 4 1 6 1 6 1 6 3 1 1 2 1 4 5 1 7 7 5 1 4 3 6 2 5 7 6 1 3 4 5 2 6 6 5 1 4 3 6 2 9 6 2 1 6 3 4 5 2 6 4 1 2 5 1 7 6 1 2 5 4 3 1 7 6 3 2 5 4 1 6
Sample Output:
Path 1: 11 (TS simple cycle) Path 2: 13 (TS simple cycle) Path 3: 10 (Not a TS cycle) Path 4: 8 (TS cycle) Path 5: 3 (Not a TS cycle) Path 6: 13 (Not a TS cycle) Path 7: NA (Not a TS cycle) Shortest Dist(4) = 8
题目大意:
这道题有点类似最小生成树类问题,给定一个地图,判断给定的路线是否遍历了整个地图,如果遍历了整个地图形成了一个环,而且每个节点只遍历了一遍(因为形成环,所以头尾节点除外),则输出TS simple cycle,如果有遍历重复的,则输出TS cycle,如果没有遍历完整,输出Not a TS cycle。结尾输出最短路线和最短路线长度。代码如下:
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
#define MAXN 210
#define INF 0x7fffffff
int G[MAXN][MAXN];
int main(){
fill(G[0], G[0] + MAXN * MAXN, INF);
int CityCnt, RoadCnt;
cin >> CityCnt >> RoadCnt;
for(int i = 0; i < RoadCnt; i++){
int l, r, v;
cin >> l >> r >> v;
G[l][r] = G[r][l] = v;
}
int QueryCnt;
cin >> QueryCnt;
int best = INF, idx = -1;
for(int _ = 0; _ < QueryCnt; _++){
vector<int> road;
bool visit[MAXN];
fill(visit, visit + MAXN, false);
int n, type = 1; //type: 1 => TS simple cycle, 2 => Not a TS cycle, 3 => TS cycle
int length = 0;
cin >> n;
for(int i = 0; i < n; i++){
int tmp;
cin >> tmp;
road.push_back(tmp);
//if(i == 0) visit[tmp] = true;
}
for(int i = 0; i < n - 1; i++){
int now = road[i], next = road[i + 1];
if(G[now][next] == INF){
type = 2;
length = INF;
break;
}else{
length += G[now][next];
if(visit[next] == true) {
type = 3;
}
visit[next] = true;
}
}
for(int i = 1; i <= CityCnt; i++)
if(visit[i] == false) type = 2;
switch(type){
case 1: printf("Path %d: %d (TS simple cycle)", _+1, length); break;
case 2: if(length == INF) printf("Path %d: NA (Not a TS cycle)", _+1);
else printf("Path %d: %d (Not a TS cycle)", _+1, length);
break;
case 3: printf("Path %d: %d (TS cycle)", _+1, length);
}
if(length < best && type != 2) best = length, idx = _+1;
cout << endl;
}
printf("Shortest Dist(%d) = %d", idx, best);
cout << endl;
return 0;
}