In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))
One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.
Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.
Output Specification:
For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.
Finally print in a line Max Heap
if it is a max heap, or Min Heap
for a min heap, or Not Heap
if it is not a heap at all.
Sample Input 1:
8
98 72 86 60 65 12 23 50
Sample Output 1:
98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap
Sample Input 2:
8
8 38 25 58 52 82 70 60
Sample Output 2:
8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap
Sample Input 3:
8
10 28 15 12 34 9 8 56
Sample Output 3:
10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap
题目大意:给出一个堆的中序序列,从右到左输出堆从上到下的路径,然后判断是大顶堆还是小顶堆还是非堆。
这道题dfs就可以了,输出路径,可以使用vector模拟一个栈,到达叶子节点就把栈内元素输出一遍。
#include <bits/stdc++.h>
using namespace std;
bool flag = true, is_maxheap;
vector<int> H, stk;
void output(){
for(int i = 0; i < stk.size(); i++){
if(i){
cout << ' ';
if((stk[i] <= stk[i - 1]) != is_maxheap)
flag = false;
}
cout << stk[i];
}
cout << endl;
}
void dfs(int idx){
stk.push_back(H[idx]);
if(idx * 2 >= H.size()) //叶子节点
output();
else{
if(idx * 2 + 1 < H.size())
dfs(idx * 2 + 1);
dfs(idx * 2);
}
stk.pop_back();
}
int main(){
int cnt;
cin >> cnt;
H.resize(cnt + 1);
for(int i = 1; i <= cnt; i++)
cin >> H[i];
if(H[1] < H[2]) is_maxheap = false;
else is_maxheap = true;
dfs(1);
if(flag){
if(is_maxheap) cout << "Max Heap\n";
else cout << "Min Heap\n";
}
else cout << "Not Heap\n";
return 0;
}