PAT-A 真题- 1099. Build A Binary Search Tree

发布于 / PAT-甲级 / 0 条评论

原题干:

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.

  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.

  • Both the left and right subtrees must also be binary search trees.

    Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format "left_index right_index", provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

    Sample Input:

    9
    1 6
    2 3
    -1 -1
    -1 4
    5 -1
    -1 -1
    7 -1
    -1 8
    -1 -1
    73 45 11 58 82 25 67 38 42

    Sample Output:

    58 25 82 11 38 67 45 73 42

题目大意:

第一行给出二叉树节点数量N,往后的几行给出从0-(N-1)的节点左右孩子编号,NULL以-1表示。最后一行给出要插入的序列。

将序列插入二叉树中,使之称为二叉搜索树,输出二叉搜索树的前序遍历结果。

对于这样将序列插入二叉搜索树的问题,我们通常的解决办法是将序列进行排序,因为二叉搜索树的中序遍历序列是有序的,所以排序后正是二叉搜索树的中序遍历序列。

接着我们使用中序插入的方式插入二叉树。

至于什么是中序插入?其实就是中序遍历的输出代码换做插入代码即可。这样就成功插入到了二叉搜索树中。

接着我们使用BFS算法进行层序遍历,得出结果。

代码如下:

#include <iostream>
#include <vector>
#include <algorithm>
#include <queue>
using namespace std;
typedef struct{
    int data;
    int lchild, rchild;
} node;
/*全局变量*/
int cnt;
node tree[110];
int input[110];
int num = 0;
/*中序递归插入*/
void insert(int root){
    if(root == -1) return;
    insert(tree[root].lchild);
    tree[root].data = input[num++];
    insert(tree[root].rchild);
}

void BFS(int root){
    queue<int> Q;
    Q.push(root);
    int sum = 0;
    while(!Q.empty()){
        int top = Q.front();
        Q.pop();
        cout << tree[top].data;
        if(++sum < cnt) cout << " ";
        if(tree[top].lchild != -1)
            Q.push(tree[top].lchild);
        if(tree[top].rchild != -1)
            Q.push(tree[top].rchild);
    }
}
int main(){
    cin >> cnt;
    for(int i = 0; i < cnt; i++)    //读入树的模型
        cin >> tree[i].lchild >> tree[i].rchild;
    for(int i = 0; i < cnt; i++)    //读入序列
        cin >> input[i];
    sort(input, input + cnt); //变成中序遍历序列
    insert(0);
    BFS(0);
    return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题- 1099. Build A Binary Search Tree
目前还没有评论,快来抢沙发吧~