The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:
-
Itai nyan~ (It hurts, nyan~)
-
Ninjin wa iyada nyan~ (I hate carrots, nyan~)
Now given a few lines spoken by the same character, can you find her Kuchiguse?
Input Specification:
Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.
Output Specification:
For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai
.
Sample Input 1:
3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~
Sample Output 1:
nyan~
Sample Input 2:
3
Itai!
Ninjinnwaiyada T_T
T_T
Sample Output 2:
nai
题目大意:给定数个字符串,求出他们的公共末尾。如果公共末尾为空,输出nai。
这道题按照题目要求进行模拟即可。
#include <iostream>
#include <algorithm>
#include <string>
using namespace std;
string ans;
bool Judge(string a){
string newans;
for( int ia = a.length() - 1, ib = ans.length() - 1;\
ia >= 0 && ib >= 0;\
ia--, ib-- ){
if(a[ia] == ans[ib]) newans += a[ia];
else break;
}
if(newans == "") return false;
reverse(newans.begin(), newans.end());
ans = newans;
return true;
}
int main(){
int cnt;
cin >> cnt;
getline(cin, ans);
getline(cin, ans);
for(int i = 1; i < cnt; i++){
string current;
getline(cin, current);
if(!Judge(current)){
cout << "nai" << endl;
return 0;
}
}
cout << ans << endl;
return 0;
}