Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (≤200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.
Output Specification:
For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.
Sample Input:
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
Sample Output:
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0
题目大意:给出选了某门课程的学生名单,要求对每个学生的查询,按照顺序输出他的选课列表。
这道题使用map会超时,所以只能写哈希函数映射成int。
这道题由于名字很有规律,前三位是A-Z的字母,最后一位是数字,可以认为前三位是一个26进制的数,最后一位是一个10进制的数,我们的哈希函数只需要将其转为10进制的,就能保证映射的唯一性了
这样映射的好处还有一个就是不会浪费空间,总共需要175760个单位的空间,开200000大小的数组足够应付~
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
//哈希函数,采用进制法,映射成int
#define hash(a) ((a[3]-'0') + (a[2]-'A')*10 + (a[1]-'A')*260 + (a[0]-'A')*26*260 )
vector<int> stu_cou[200000];
int main(){
int qcnt, icnt;
cin >> qcnt >> icnt;
for(int i = 0; i < icnt; i++){
int idx, cnt;
cin >> idx >> cnt;
while(cnt--){
char name[5];
cin >> name;
stu_cou[hash(name)].push_back(idx);
}
}
for(int i = 0; i < qcnt; i++){
char name[5];
cin >> name;
cout << name << ' ' << stu_cou[hash(name)].size();
sort(stu_cou[hash(name)].begin(), stu_cou[hash(name)].end());
for(auto st : stu_cou[hash(name)])
cout << ' ' << st;
cout << endl;
}
return 0;
}