A long-distance telephone company charges its customers by the following rules:
Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.
Input Specification:
Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.
The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.
The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm
), and the word on-line
or off-line
.
For each test case, all dates will be within a single month. Each on-line
record is paired with the chronologically next record for the same customer provided it is an off-line
record. Any on-line
records that are not paired with an off-line
record are ignored, as are off-line
records not paired with an on-line
record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.
Output Specification:
For each test case, you must print a phone bill for each customer.
Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm
), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.
Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80
题目大意:第一行给定24个小时的费率,然后给定一大堆通话记录,格式为:
名字 时间 状态
把能配对的记录找出来,按照姓名的字母序打印账单。
这道题对所有记录执行一次排序,然后计算即可。按照时间戳的方式计算会比较方便。对于计算费用,也可以按照类似时间戳的形式来记录。
代码:
#include <iostream>
#include <algorithm>
#include <string>
#include <map>
#include <vector>
#include <cstdio>
using namespace std;
typedef struct{
string name; //客户名字
int timestamp; //时间戳
bool status; //呼叫/挂断标志 true=>呼叫 false=>挂断
int dd, hh, mm;
} node;
bool cmp(node a, node b){
if(a.name != b.name) return a.name < b.name;
if(a.timestamp != b.timestamp) return a.timestamp < b.timestamp;
if(a.status != b.status) return a.status > b.status;
}
int GetTimestamp(int dd, int hh, int mm){
return dd * 24 * 60 + hh * 60 + mm;
}
int rate[25] = {0}, day_rate = 0; //rate存放费率,rate_add存放费率累加,为了更方便计算
double GetBill(node a){
double ans = 0.0;
ans += a.dd * day_rate * 60;
for(int i = 0; i < a.hh; i++)
ans += rate[i] * 60;
ans += a.mm * rate[a.hh];
return ans / 100.0;
}
int main(){
vector<node> L;
int add = 0;
for(int i = 0; i < 24; i++){//读取费率
scanf("%d", &rate[i]);
day_rate += rate[i];
}
int cnt, MM; //MM存放月份
scanf("%d", &cnt);
for(int i = 0; i < cnt; i++){ //读取全部数据
node temp;
cin >> temp.name;
scanf("%d:%d:%d:%d", &MM, &temp.dd, &temp.hh, &temp.mm);
temp.timestamp = GetTimestamp(temp.dd, temp.hh, temp.mm);
string stat;
cin >> stat;
temp.status = stat == "on-line";
L.push_back(temp);
}
sort(L.begin(), L.end(), cmp);
map<string, vector<node> > record; //string=>vector<node>映射
//遍历记录,选出合法记录,存到map中
for(int i = 1; i < L.size(); i++){
if( L[i].name == L[i-1].name && //前后两条记录的名字一样
L[i].status == false && L[i-1].status == true){ //前面是呼叫,后面是挂断
record[L[i].name].push_back(L[i-1]); //前后两条记录放到map中
record[L[i].name].push_back(L[i]);
}
}
//遍历map
for(map<string, vector<node> >::iterator it = record.begin(); it != record.end(); it++){
printf("%s %02d\n", it->first.c_str(), MM);
double total = 0.0;
for(int i = 0; i < it->second.size(); i += 2){
int time = it->second[i+1].timestamp - it->second[i].timestamp; //时间差
double amount = GetBill(it->second[i+1]) - GetBill(it->second[i]); //费用
total += amount; //累加器
printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.02f\n", it->second[i].dd,
it->second[i].hh,
it->second[i].mm,
it->second[i+1].dd,
it->second[i+1].hh,
it->second[i+1].mm,
time,
amount);
}
printf("Total amount: $%.02f\n", total);
}
return 0;
}