If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut
(Galleon
is an integer in [0,107], Sickle
is an integer in [0, 17), and Knut
is an integer in [0, 29)).
Input Specification:
Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input.
Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28
题目大意:进制转换
这道题很简单,不做详细解释。
#include <stdio.h>
int main(){
int a[3], b[3];
scanf("%d.%d.%d", &a[0], &a[1], &a[2]);
scanf("%d.%d.%d", &b[0], &b[1], &b[2]);
for(int i = 0; i < 3; i++) a[i] += b[i];
a[1] += (a[2] / 29), a[2] %= 29;
a[0] += (a[1] / 17), a[1] %= 17;
printf("%d.%d.%d\n", a[0], a[1], a[2]);
return 0;
}