Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).
Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 105. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.
Output Specification:
For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.
Sample Input:
4 0.1 0.2 0.3 0.4
Sample Output:
5.00
题目大意:给定n个数字,求这n个数字所有相邻序列的和。
直接暴力会超时,正确的做法是分析一下在所有序列中,每个数字被加了几次。
当序列元素个数为1时,第一个元素加了1*1次
当序列元素个数为2时,第一个加了1*2次,第二个加了2*1次
当序列元素个数为3时,第一个加了1*3次,第二个加了2*2次,第三个加了3*1次
通过这样的规律,我们就能写出以下程序:
#include <cstdio>
#include <iostream>
using namespace std;
int main(){
int n;
cin >> n;
double ans = 0.0;
for(int i = 1, x = n; i <= n; i++, x--){
double input, co = 1.0 * i * x; //不加1.0会导致后两个测试点error
cin >> input;
ans += co * input;
}
printf("%.2f", ans);
return 0;
}