PAT-A 真题 – 1093 Count PAT's

发布于 / PAT-甲级 / 0 条评论

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 10^5^ characters containing only P, A, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

题解看这里:https://www.mmuaa.com/post/3a3ebb7bbdadf7d3.html

#include <iostream>
#include <algorithm>
#include <string>
using namespace std;

int main(){
  string pat;
  cin >> pat;
  long long ans = 0;
  int p = 0, a = 0, t = 0;
  //统计有多少T 
  for(int i = 0; i < pat.length(); i++)
    if(pat[i] == 'T') t++;
  
  for(int i = 0; i < pat.length(); i++){
    switch(pat[i]){
      case 'T':
        t--;
        break;
      case 'P':
        p++;
        break;
      case 'A':
        ans += p * t;
    }
  }
  cout << ans % 1000000007 << endl;
  return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题 – 1093 Count PAT's
目前还没有评论,快来抢沙发吧~