A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.
Input Specification:
Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:
ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.
Sample Input:
23 13 21 1 23 01 4 03 02 04 05 03 3 06 07 08 06 2 12 13 13 1 21 08 2 15 16 02 2 09 10 11 2 19 20 17 1 22 05 1 11 07 1 14 09 1 17 10 1 18
Sample Output:
9 4
题目大意:给出一颗家庭关系树,01为根,算出人最多的一代,并求出由多少人
这是一个树的层序遍历问题,使用带层级的BFS算法即可。
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#define MAXN 101
using namespace std;
typedef struct{
int id, layer;
} node;
vector<int> T[MAXN];
int fuck[MAXN] = {0};
void BFS(int root){
queue<node> Q;
Q.push({root, 1});
while(!Q.empty()){
node it = Q.front();
Q.pop();
fuck[it.layer]++;
for(int i = 0; i < T[it.id].size(); i++){
node new_fuck;
new_fuck.id = T[it.id][i];
new_fuck.layer = it.layer + 1;
Q.push(new_fuck);
}
}
}
int main(){
int N, M; //n为节点数量,m为非叶子节点数量
cin >> N >> M;
for(int i = 0; i < M; i++){
int root, sum;
cin >> root >> sum;
for(int j = 0; j < sum; j++){
int _;
cin >> _;
T[root].push_back(_);
}
}
BFS(1);
int max = 0, layer = 0;
for(int i = 0; i < MAXN; i++){
if(fuck[i] > max){
max = fuck[i];
layer = i;
}
}
cout << max << ' ' << layer << endl;
return 0;
}