PAT-A 真题 - 1092 To Buy or Not to Buy

发布于 / PAT-甲级 / 0 条评论

Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is "Yes", please tell her the number of extra beads she has to buy; or if the answer is "No", please tell her the number of beads missing from the string.

For the sake of simplicity, let's use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

Snip20160706_29-300x239.png

Input Specification:

Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

Output Specification:

For each test case, print your answer in one line. If the answer is "Yes", then also output the number of extra beads Eva has to buy; or if the answer is "No", then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

Sample Input 1:

ppRYYGrrYBR2258
YrR8RrY

Sample Output 1:

Yes 8

Sample Input 2:

ppRYYGrrYB225
YrR8RrY

Sample Output 1:

No 2

题目大意:每一个字符代表一种柱子,第一行代表商店有的,第二行代表想要买的,买就必须买下一整串。问商店的珠子够不够。够就输出需要多买几个,不够就输出还需要几个。

代码如下:

#include <iostream>
#include <algorithm>
#include <cstring>
#define MAXN 1010 
using namespace std;

int main(){
  char shop[MAXN], buy[MAXN];
  cin >> shop >> buy;
  int missing = 0;
  for(int i = 0; i < strlen(buy); i++){
    char it = buy[i];
    bool flag = false;
    for(int j = 0; j < strlen(shop); j++){
      if(shop[j] == it){
        shop[j] = '#';
        flag = true;
        break;
      }
    }
    if(!flag) missing++;
  }
  if(missing)
    cout << "No " << missing << endl;
  else cout << "Yes " << strlen(shop) - strlen(buy) << endl;
  return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题 - 1092 To Buy or Not to Buy
目前还没有评论,快来抢沙发吧~