Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤105). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.
Output Specification:
Print in a line the smallest positive integer that is missing from the input list.
Sample Input:
10 5 -25 9 6 1 3 4 2 5 17
Sample Output:
7
题目大意:给定n的数字,求出最小的没有出现的正整数。
这道题记录所有的正整数,然后排序即可。但是要注意给定数字可能有重复的!
这道题使用set再合适不过了,自动排序,去重,美滋滋~
代码:
#include <iostream>
#include <set>
using namespace std;
int main(){
int cnt;
cin >> cnt;
set<int> input;
for(int i = 0; i < cnt; i++){
int tmp;
cin >> tmp;
if(tmp > 0) input.insert(tmp);
}
int num = 1;
for(set<int>::iterator it = input.begin(); it != input.end(); it++){
if(num != *it)
break;
num++;
}
cout << num;
return 0;
}