In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))
Your job is to tell if a given complete binary tree is a heap.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.
Output Specification:
For each given tree, print in a line Max Heap
if it is a max heap, or Min Heap
for a min heap, or Not Heap
if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.
Sample Input:
3 8 98 72 86 60 65 12 23 50 8 38 25 58 52 82 70 60 10 28 15 12 34 9 8 56
Sample Output:
Max Heap 50 60 65 72 12 23 86 98 Min Heap 60 58 52 38 82 70 25 8 Not Heap 56 12 34 28 9 8 15 10
题目大意:给定完全二叉树的层序遍历序列,判断这个二叉树是大顶堆还是小顶堆还是根本就不是堆。
再输出二叉树的后序遍历序列。
判断是不是堆,只需要判断每一个节点的左右孩子即可,特别注意小心叶子节点或没有右孩子的节点发送越界。
代码:
#include <iostream>
using namespace std;
#define MAXN 1010
//判断堆的类型
void Judge(int H[], int qcnt){
if(H[1] > H[2]){ //只能是大顶堆或非堆
for(int i = 1; i <= qcnt; i++){
int lchild = 2 * i, rchild = 2 * i + 1;
if( (lchild <= qcnt && H[lchild] > H[i]) || \
(rchild <= qcnt && H[rchild] > H[i])
) {
cout << "Not Heap";
return;
}
}
cout << "Max Heap";
}else{ //只能是小顶堆或非堆
for(int i = 1; i <= qcnt; i++){
int lchild = 2 * i, rchild = 2 * i + 1;
if( (lchild <= qcnt && H[lchild] < H[i]) || \
(rchild <= qcnt && H[rchild] < H[i])
) {
cout << "Not Heap";
return;
}
}
cout << "Min Heap";
}
}
//静态二叉树的递归后序遍历
void PostOrder(int root, int H[], int qcnt, bool space){
if(root > qcnt) return; //叶子节点,直接ban
int lchild = 2 * root, rchild = 2 * root + 1; //定义左孩子和有孩子
PostOrder(lchild, H, qcnt, true);
PostOrder(rchild, H, qcnt, true);
cout << H[root];
if(space) cout << ' '; //是否输出空格
}
int main(){
int icnt, qcnt;
cin >> icnt >> qcnt;
while(icnt--){
//定义静态树
int H[MAXN];
//读入层序序列
for(int i = 1; i <= qcnt; i++)
cin >> H[i];
//执行判断
Judge(H, qcnt);
cout << endl;
//执行后序遍历
PostOrder(1, H, qcnt, false);
cout << endl;
}
return 0;
}