原题干:
A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.
Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits aias the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.
Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.
Input Specification:
Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated by a space.
Output Specification:
For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "ak ak-1 ... a0". Notice that there must be no extra space at the end of output.
Sample Input 1:
27 2
Sample Output 1:
Yes 1 1 0 1 1
Sample Input 2:
121 5
Sample Output 2:
No 4 4 1
题目大意:给定两个数:N和b,问将N转化成b进制数字后,这个数字是不是回文数?
对于转进制,我们可以采用除基取余法转换进制。
反转可以用C++Algorithm里面的reverse函数直接反转。
特别注意的是这道题绝对不可以用string或者cstring来做,因为char的最大值只有127,会溢出!
代码:
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
void Judge(int num, int d){
vector<int> ans, ans_rev;
do{
ans.push_back(num % d);
num /= d;
} while(num);
ans_rev = ans;
reverse(ans.begin(), ans.end());
if(ans == ans_rev) cout << "Yes" << endl;
else cout << "No" << endl;
for(int i = 0; i < ans.size(); i++){
if(i) cout << ' ';
cout << ans[i];
}
}
int main(){
int num, d;
cin >> num >> d;
Judge(num, d);
return 0;
}